At Xplornet we take protecting your data very seriously. To ensure the security of your personal information and to keep us aligned with industry-wide best practices, we will upgrading our security measure Transport Layer Security – or TLS – for our MyXplornet customer portal from TLS 1.0 to TLS 1.1 in March of 2018.

What is TLS

TLS provides secure communications on the Internet for such things as email, Internet faxing, and other data transfers.

What will you see when you visit MyXplornet.com after March 2018?

If you are running TLS 1.0 or  you are using an unsupported browser, you will not be able to access the site, and instead, you will receive an error message. We recommend you update your browser and/or settings prior to this date.

Supported Browsers

The following browsers support the security changes and no action is required on your part:

  • Internet Explorer 11 (Desktop & Mobile)
  • Internet Explorer 8,9,10 (Desktop – Compatible but not enabled by default; see procedures below to enable settings)
  • Firefox 27 and higher
  • Google Chrome 38 and higher
  • Google Android 5.0 and higher
  • Safari 7 on OSX 10.9 (Mavericks) Desktop and higher
  • Safari 5 on iOS 5 Mobile and higher

The following operating systems are not compatible with TLS 1.1 or higher and we recommend that you upgrade your operating system to a supported system:

  • Windows XP
  • Windows Vista
  • Server 2008
  • Server 2003

If you are unable to access MyXplornet.com after March 4th and you have a browser or operating system that does not support TLS 1.1 or 1.2, please complete the update steps outlined below.

Browser

Instructions

Identify your browserInternet Explorer1. Open Internet Explorer

2. Select Tools or Help

3. Click About Internet Explorer

Firefox1. Click the Firefox menu from the menu bar

2. Click About Firefox

Google Chrome1. Click the Menu button

2. Click Help

3. Click About Google Chrome

Safari1. Click Safari in the browser menu

2. Click About Safari

To update your browser settings, please follow the steps outlined below:

Internet Explorer 11 – Compatible with TLS 1.1 or higher by default

If the message “Stronger security is required” appears on MyXplornet.com after March 2018, turn off the TLS 1.0 setting:

1.     Open Internet Explorer

2.     Click Tools

3.     Click Internet Options

4.     Click Advanced and uncheck Use TLS 1.0

5.     Click Apply

Internet Explorer 8, 9 or 10

1.     Open Internet Explorer

2.     Click Tools

3.     Click Internet Options

4.     Click Advanced and check Use TLS 1.1 and Use TLS 1.2

5.     Click Apply

Internet Explorer 7 or earlier – You must upgrade your browser

Google Chrome – You must have have Windows 7 or a newer operating system

Firefox version 26 or earlier – You must have Windows XP Service Pack 2 or newer

Safari – versions older than 7 on OSX 1.9 (Mavericks) – TLS 1.1 and TLS 1.2 are not supported, so you must use Google Chrome for MAC

Once you’ve completed the updates above, restart your browser and go to MyXplornet.com to check that the changes have taken effect. If you have TLS 1.1 or 1.2 enabled correctly, you should be able to access MyXplornet after the TLS update in March of 2018.

What you’ll find here

Steps for upgrading your browsers’ Transport Layer Security – or TLS – from TLS 1.0 to TLS 1.1.